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Welcome

The Rover 5 Seeeduino/Arduino Robot Kit is a robot kit that combines the powerful Rover 5
chassis, with a Seeeduino (an Arduino compatible controller board) to give you a complete
robot with loads of great features. The kit is easy to assemble, and accessible for beginners,
whilst providing the flexibility that more experienced robot builders need to build advanced
robotic projects.

Features

® Rugged Tank chassis with 2 powerful motors

e Encoders with 1000 pulses every 3 wheel revolutions

e Motor current sensing

¢ 4 corner mounted Infra Red sensors

e Ultrasonic Range Sensor mounted on a pan/tilt head

* 6xAA battery holder (batteries not included)

e NiMh batteries can be trickle charged using a 9-12V DC Power Adaptor (not included)

Kit Contents

Please carefully check the contents of your kit against this list before you begin assembly. If
anything is missing, please contact sales@dawnrobotics.co.uk.

1 x Dagu Rover 5 Robot Chassis - (2 Motors and 2 Encoders)

1 x Dagu Explorer PCB for Rover 5

1 x Seeeduino V3.0 (Atmega 328P) - Arduino Compatible Board
1 x 40 Pin Dual Male Splittable Jumper Wire - 300mm

2 x Jumpers

1 x Jumper Cable - 200mm Female to Female - 3 Pin

1 x Dagu Sensor Pan/Tilt Kit

1 x SeeedStudio - Ultrasonic Range Measurement Sensor Module
1 x Sensor Fixing Set

4 x Cable ties

1 x USB to mini-USB cable

Extra Requirements

e A computer
e 6xAA Rechargeable batteries NiMh or NiCd. These should ideally be high capacity
batteries i.e. 2400mAh

Note: It is possible to run this robot with Alkaline (non-rechargeable) batteries. However you
may find that they are unable to supply the current that the robot needs for extended
periods of time. Also, if you do use Alkaline batteries do NOT attempt to use the trickle
charge feature by attaching a power adaptor to the barrel jack on the Explorer PCB.
Attempting to charge Alkaline batteries in this way can result in fire/carnage etc.



Testing the Seeeduino

Before we dive into assembling the robot, we're going to put a simple test program on the
Seeeduino. This will confirm that the Seeeduino is working, and provide a useful way of
testing that the robot power wires have been attached correctly later on.

1. Download and install the Arduino IDE - Select the appropriate package for your
operating system at http://arduino.cc/en/Main/Software. Depending upon your
platform, it may also help if you have a look at the getting started guide for your platform
at http://arduino.cc/en/Guide/HomePage.

2. Connect the Seeeduino to your computer with the supplied USB cable.

3. Select the Blink example sketch. File > Examples > 1.Basics > Blink.

@ Blink | Arduino 1.0.3 -o@
File Edit Sketch Tools Help

Blink
/*
Blink
Turns on an LED on for cne second, then off f¢

This example code is in the public domain.
®E

/f Pin 13 has an LED connected on most Arduino &
/f give 1t a name:
int led = 13;

/i the setup routine runs once when you press re_
void setup() {
/¢ initialize the digital pin as an output.
pinMede(led, OUTPUT);
}
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4, Select the serial port for your Seeeduino from the Tools > Serial Port menu.

5. Select the correct board type. From the Tools > Board menu. The Seeeduino
corresponds to a 'Arduino Demilanove w/ ATmega328'.

Arduino 1.0.3 —o@
zetch Help
Auto Format Ctrl+T ’
Archive sketch
Fix Encoding & Reload
Serial Monitor ctrl+shift+m "‘
NN Board ' Arduino Uno
Serial Port ' Arduino Duemilanove w/ ATmega328
<ampl Programmer L Arduino Diecimila or Duemilanove w/ ATmega1638
Burn Bootloader Arduino Nano w/ ATmega328
3 has an LED connected on most Ar( Arduino Nanow/ATmegalés
t 3 name: Arduino Mega 2560 or Mega ADK
= 13; Arduino Mega (ATmega1280)

Arduino Leonardo
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up () { -
ialize the digital pin as an out; Arduino Micro
:(led, OUTPUT); Arduino Mini w/ ATmega328
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http://arduino.cc/en/Main/Software
http://arduino.cc/en/Guide/HomePage

6. Program the Seeeduino by pressing the 'Upload' button.

If all goes well, you should now see a blinking LED on your Seeeduino. Congratulations!
Moreover, because the program is programmed into the Seeeduino's memory, the blink
program remains even if you unplug the Seeeduino, and will run whenever it's powered on.

Assembling and Wiring the Robot

We're now ready to assemble the robot. Take things slowly, and check the wiring carefully as
you go. In most situations, getting wires the wrong way round will not have any bad effects,
apart from the robot not working correctly. However, if you get the power lines on your
Seeeduino, Servos or Ultrasonic Sensor the wrong way round they are likely to be destroyed.
With that dire warning out of the way, lets begin.

1. Attach the encoder wires and motor wires of the Rover 5 chassis to the base of the
Explorer PCB. Pay attention to the polarity of the power connections for the encoders.
Red wires are +V, Black wires are ground. Don't worry about the polarity of the motor
wires as they should only connect in one orientation, and it only affects the direction the
motors turn,

It doesn't matter if you swap the yellow and white wires of the encoders. This will only
reverse the sense of direction and can be easily corrected either in the software or with
the wiring on the upper side of the board.




2. Put batteries in the battery holder and attach the battery holder to the base of the

Explorer PCB. The connector should only go in one way round.

3. Attach 3 brass standoffs for the Seeeduino to the holes marked in orange.

4. Attach brass standoffs to one of the mini servos of the pan/tilt kit. The holes on the

servos are a bit small, so you may need to widen the holes before the screws will fit. This

can be done fairly easily by using a small flat headed screwdriver.

5. Now attach the servo standoffs to the Explorer PCB.
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6. Put the motor wires and the battery holder into the Rover 5 chassis, and use then the
long self tapping screws to attach the Explorer PCB to the Rover 5 chassis. Tip: It can be
tough to cram all of the wires into the base, a bit of blu-tak and/or sellotape can be very
useful here to hold wires in place.
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8. Connect power to Seeeduino using 2 wires (Brown and Red are good) from the set of
40 male to male jumper wires, as shown on the diagram below. Things can be kept tidy
by wrapping excess wire length around the brass standoffs. The connections to make are
VCC to 5V and GND to GND. Note: Ensure that the Seeeduino voltage is set to 5V.
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9. Test the Seeeduino by turning on the power switch at the back of the Explorer PCB, if
all is well you should see a flashing LED on the Seeeduino. If you don't see a flashing LED
then test the Seeeduino on its own by reconnecting it to the PC with the USB cable. Also,
check the wiring.

10. Wire up the motors. The connections to make are, Digital 11 to Left PWM, Digital 12
to Left DIR, Digital 6 to Right PWM, Digital 7 to Right DIR.
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11. Wire up the encoders. The connections to make are Digital 2 to Right Encoder 1,
Digital 4 to Right Encoder 2, Digital 3 to Left Encoder 1, Digital 5 to Left Encoder 2.
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13. Wire up the corner mounted IR LEDs. The connections to make are Analog 0 to Signal

In 1, and Analog 1 to Signal In 3.
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14. Wire up the corner mounted IR sensors. The connections to make are Analog 2 to
Signal Out 1, Analog 3 to Signal Out 2, Analog 4 to Signal Out 3, and Analog 5 to Signal

Out 4. . )
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15. Assemble the pan/tilt head and attach it to the brass standoffs
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17. Now connect 5V power to the left hand power line. The connection to make is VCC to

16. Use the sensor fixing set to attach the ultrasonic sensor to the pan/tilt head
122 SRV.

IRt b Re4 ke



18. Connect the servos for the pan/tilt neck to the Explorer PCB. The servo wires are
coloured as follows; Ground is brown, VCC is red (and in the centre), and the Signal wire
is orange. The connections to make for the pan servo are Ground to J15 GND, VCC to J15
+V1, and Signal to J15 Signal. The connections to make for the tilt servo are Ground to
J13 GND, VCC to J13 +V1, and Signal to J13 Signal.
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Servo / Sensor pooooooooDooot pcooopoo ooo Servo / Sensor
Male / Female Header HUOU0R00000000 Male / Female Header
GND, +V1, Signal ¢ oooooooooooo| Signal, +V2, Gnd

Servo / Sensor

Male / Female Header
GND, +V1, Signal
Servo / Sensor

Male / Female Header ooooooooooDn!
GND, +V1, Signal

Servo / Sensor

Male / Female Header
Signal, +V2, Gnd
Servo / Sensor

Male / Female Header
Signal, +V2, Gnd

19. Connect the ultrasonic sensor to the Explorer PCB using the 3 wire female to female
jumper cable. The connections to make are GND to J17 GND, VCC to J17 +V1, and SIG to
J17 Signal.
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20. Now connect signal wires for the pan/tilt servo motors, and for the ultrasonic sensor
to the Seeeduino. The connections to make are Digital 8 to J16 Signal, Digital 9 to J14
Signal, and Digital 10 to J12 Signal.
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Servo / Sensor <+ U Servo / Sensor
Maie / Female Header ~“000Qog0 Male / Female Header
GND, +V1, Signal . = Signal, +V2, Gnd
Servo / Sensor = -~ Servo / Sensor
Male / Female Header Male / Female Header
GND, +V1, Signal Signal, +V2, Gnd

21. Wire up the motor current sensors to the Seeeduino. This will let the Seeeduino
sense when a motor has stalled. The connections to make are ADC6 to left CUR and
ADCY7 to right CUR.
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21. Finally, keep the robot's wires tidy by using some of the provided cable ties to bind
them together
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Programming your Robot

In order to program your robot, you connect the Seeeduino to the PC using the USB cable,
and then upload a program from the Arduino IDE as we did earlier. You can find an example
program at http://www.dawnrobotics.co.uk/content/rover_5 wall_follower.zip. Unzip the
program on your computer and navigate to it with the Arduino IDE. You should then be able
to upload it to your Rover 5 (make sure that the power switch at the back of the Rover is off
at this point). Once the program is uploaded put the robot down on the floor and turn it on.
You should find that it drives forwards until it finds a wall, it then turns left and attempts to
follow the wall, keeping the wall on its right hand side.

If the head of the robot doesn't face forwards when it first starts looking for a wall, or doesn't
look to the right properly when following the wall, then you may need to modify the
constants called LOOK_FORWARD_PAN/TILT_ANGLE and LOOK_RIGHT PAN/TILT_ANGLE in
the main program file (called rover_5_wall_follower).

Warning: The Rover 5 robot should not be left to run on its own, as it can quite easily drive
off the edge of stairs, become stuck or otherwise damage itself if left unattended. The Rover
5 kit is not a polished consumer product but rather a platform for research, education and
experimentation. If nothing else, watching the Rover 5 drive around, and experimenting with
making changes to its software for a while should convince you of the challenges involved
with equipping a robot for fully autonomous operation!

Troubleshooting

If you have any problems with the assembly and/or programming of this robot kit, then you
can look for answers on our support forum at http://forum.dawnrobotics.co.uk.

Taking Things Further

With any luck, you should now have a complete robot which drives round trying to follow the
walls. This is just the beginning though, there's lots to learn and do with your new robot. For
a start, you can get a greater understanding of the parts that make up the kit. More
information about each of the robot's components, such as the Explorer PCB and Ultrasonic
sensor can be found on the Dawn Robotics website, along with links to manuals and sample
code.

The Artificial Intelligence (Al) of the robot can be improved a lot, and you can re-program the
robot to perform a number of different actions in response to the information it gets from its
sensors. You could program the robot to solve a maze, or to explore the rooms of your house.
Extra sensors can also be added onto the robot to give it more information about the
environment it's exploring. Many interesting behaviours can be achieved by adding a light
sensor to the robot and getting it to seek out light source for example.

Wireless communications can be added to the robot using either a Bluetooth shield or a WiFi
shield, and once this is done you can control the robot from an external computer or
smartphone.

So, the possibilities are many and varied. Have fun!
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